Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

electronic transmission control module indicator came on

Discussion in 'DIY (Do-It-Yourself)' started by overcrush22, May 20, 2008.

    overcrush22 guest

    Post Count: 2
    Likes Received:0
    electronic transmission control module indicator came on after draining and servicing both engine oil and transmission oil pan, cleaned the tranny pan and the magnet real good bcoz there's a lot of gunk and it looks like mud. i also replace the spark plugs both air and oil filter, the engine service soon light is been on for a few days so i had it reset from one of the shop then it came back on, so i did the all servicing my self, after i filled the engine oil and replace the oil filter i tried to fill up the ATF can with ATF fluid but noticed it only took a little i didnt even used the whole qt. and i drained a lot of fluid out of the tranny pan, is there anybody that knows how to completely fill the tranny back up? and also any suggestion why the indicator came on? i will greatly appreciate the help. i just had my e46 (m3 02) a couple weeks ago from a friend and it's my first time working on this type of car. any suggestion will be greatly appreciated.


    aloha5280 guest

    Post Count: 1
    Likes Received:0
    Mine came on last night

    Any info? My 95 325ic had her light come on last night on the way home from the airport. I pulled over and looked it up as I've not had this car very long. It sounded like she would stay in 4th and be OK to get home (about 5 miles)... I have a friend who is a master mechanic with GM who is going to take a look...

Share This Page