Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

E60 cam sensor code

Discussion in 'E60 (2004-2010)' started by bransan, Oct 19, 2014.

    • Member

    bransan Master troubleshooter

    Post Count: 21
    Likes Received:1
    I have a 07' 525xi. Lately I've been getting a p0115 code, ( cam position sensor over retarded ) I think it was bank "B". I don't notice any runability issue, just get the CEL. When I scan it I get the same code. Also getting a heater circuit code, but that doesn't set the CEL. I am wondering if this is a vanos problem? I have 125000 mi on the clock. any body have a similar issue and fixed it?
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,252
    Likes Received:126
    Could be a vanos solenoids that has jammed on you causing vanos problems. BMW has a bulletin stating to change both solenoids and do a oil change the vehicle. My suggestion would be to remove the oil filter cap and check to make sure the center cone is still there if not thats your problem. If it is I would removed the solenoids and try to clean them with brake clean/ parts cleaner and do a oil change then reinstall clear faults and test drive see if the light stays away if not you will need to replace them. But with your mileage it could also be a cam sensor you could swap the two and clears faults and see if the fault switches to the other side. Hope this helps.
    • Member

    bransan Master troubleshooter

    Post Count: 21
    Likes Received:1
    Thanks for the reply, I appreciate Your suggestions. What do You mean by the cone in the filter cap. The thing with the little "o"ring that comes with the filter element? Yes that is still there. One time after changing the oil I had a terrible time with the engine not running well and wouldn't idle at all. I managed to keep it running and took it for a ride down the road and floored it for few seconds and she snapped out of it. Could these things be related? I am going to do the vanos thing with brake clean. I have an oil change coming up soon. I will try the sensor swap if that doesn't fix it.

    I am also going to research exactly how the vanos works to better understand it.
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,252
    Likes Received:126
    If the little o ring in the center of the filter is there then the cone is there. Could also be vanos for the runs rough issue hard to say. Please do read about the vanos it is a very neat system.
    • Member

    hackmechanic

    Post Count: 40
    Likes Received:2
    Sorry, out of my depth, never owned anything this new. Thanks for chiming in.

Share This Page