Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

TX State Inspections and OBDII connection

Discussion in 'E60 (2004-2010)' started by cpri@chevron.com, Jul 26, 2011.

    cpri@chevron.com guest

    Post Count: 1
    Likes Received:0
    Hi. My E60 was due state inspection this month and I've taken it to several places now including a dealership and they have been unable to "connect" to the Tx State system to finalize my emissions testing. Haven't gotten to the bottom of this yet but the physical connection of the OBDII connector seems to be fine. Has anyone else had this issue and if so, how was it remedied?
    Regards,
    boneman
    • Member

    MGarrison

    Post Count: 2,842
    Likes Received:144
    I hope somebody here may have

    I hope somebody here may have some insight, but you should try the other BMW-specific forums out there, as most folks here who were actively participating are now waiting for a forum revamp - thus, traffic is pretty slow and that sounds like such a model-specific fluke/issue, you need to find others with experience specific to your car.

    Even if your car's out of warranty, you might try a call to BMW. What does Texas do for certifying pre-obd cars? Can't they manually test and measure your emissions so you can get your registration? It would seem short-sighted of Texas to not have an alternative in case of car-specific electronic glitches...

Share This Page