Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

Turn signal click doesn't

Discussion in 'E90/E91/E92/E93 (2006-2011)' started by yobyot, Apr 26, 2009.

    • Member


    Post Count: 2
    Likes Received:1
    My first post!

    I have an '06 330iA (E90) with iDrive. Picked up the car via ED and love it.

    I just exceeded the mileage for the original warranty, and it looks like my fears of the car "waiting" to start acting up have begun. (Until now and for 54K miles, it's been perfect.)

    Friday on the way home from work, I had the turn signal on and suddenly, the "click-click" noise that audibly indicates the turns signals are on stopped. You'd be surprised how quickly you notice something like that.

    When I got home, I let the car sit until it went into deep sleep. Then, I started it up, and the click-click sound was back. I drove the car about two miles, and in mid-turn-signal click, it stopped again.

    Because the previous week I'd had an iDrive "low battery charge" warning and because I believe (please correct me if I'm wrong) that this clicking sound is NOT mechanical but electronic, I decided to "reset" the car by disconnecting the battery.

    I left the battery disconnected for about an hour, reconnected it and once again, I had the click-click noise when signaling a turn...and once again about two miles after starting to drive, it stopped.

    Also, after reconnecting the battery, I received a second "low batter charge" warning, which disappeared after starting the car.

    My question is: is the disappearance of the clicking noise related to the low battery? (It's a four year old car that's been through four New England winters, I am not surprised the battery may need replacement.)

    All speculations appreciated.


Share This Page