Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

Tire Pressure Monitor issue on M3

Discussion in 'Wheels & Tires' started by stangman1, Jun 25, 2010.

    • Member

    stangman1

    Post Count: 3
    Likes Received:0
    Looking for some insight on a TPS sensor issue I am having on my 2003 M3 with 8500 miles on her. TPS light comes on regularly but tire pressure is fine?

    Does this model have wheel or rotation sensors? Anyone else seen this problem?

    Suggestions would be welcome.

    Thanks
    • Member

    03BeastCharmer

    Post Count: 128
    Likes Received:4
    8,500 Miles.... Wow, that is low.

    The E46 M3 doesn't have the wheel mounted TPMS. If your pressures are fine, I think you just need to get them at the right pressures, and then reset the system. I've had to do that a couple times with my '03 5 series when the weather has changed. Instructions should be in the Owners Manual, and generally require resetting, and then driving for a few miles so it learns the expected "wheel diameters".
    • Member

    stangman1

    Post Count: 3
    Likes Received:0
    Ya real barn find !!

    Seems like if I set the tire pressures to a desired value and hit the reset, it should hold as good?

    Will try it again. If there are no wheel TPS sensors than it must be run off the ABS sensors which will be a bigger bugger to address if I am unsuccessful.

Share This Page