Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

iPod Adapter Stopped Working

Discussion in 'E90/E91/E92/E93 (2006-2011)' started by Zahnarzt, Jun 26, 2009.

    • Member

    Zahnarzt

    Post Count: 61
    Likes Received:1
    I had the original BMW iPod adapter installed by the dealer when I picked up my 2006 E90 330xi back in the states, and it worked flawlessly with my iPod Mini, iPod Touch gen 2, and wife's iPhone 3G until recently. Now all I get whenever I select CD from the menu on iDrive is the message "Loading changer contents..." The audio source doesn't click over like it usually did as soon as I select it, even if it took a few seconds to play. I unplug the iPods and plug them back in, and still no dice. I've rebooted all of them with no luck, either. As you can see by the picture, I do get the little BMW graphic on the iPod when I plug it in, and all the things appear to charge OK, so there is at least some communication going back and forth.

    All of this happened after I took the iPod to the dealer for a headlight just before I rolled out of warranty about a week ago. They also cleared two service indicators, but other than that, they didn't flash the ECU or anything. The service advisor said that the actual plugs wear out all the time, but that strikes me as a bit odd considering how often I don't plug/unplug.

    I did see a post on another forum where one guy started to have issues when he upgraded to iTunes 8, but that seems to be really isolated, and BMW NA has listed no known issues.

    Any ideas? Since I'm out of warranty now, the dealer wants $150 just to look.
    :( Rick
    • Member

    Swooz

    Post Count: 42
    Likes Received:1
    iPod Touch issues on my 328i

    I am having connectivity issues with my iPod Touch on my 2009 328i whenever I disconnect from the USB to add songs and/or update the iTunes software. Last time it took five days for the car to read my iPod.

    Also having unrelated (?) Bluetooth issues, even after replacing my older BMW-approved phone with a newer approved phone. Sometimes it's paired, but often times it is not.

    The tech at BMW of Annapolis could not find ANYTHING out of the ordinary so I picked it up last night and fully expect my problems will continue. It's frustrating to spend $40K plus for a BMW and have quirky stuff like this going on.

    Is anyone else having these issues and if so, what did you dealer do for you?
    • Member

    Zahnarzt

    Post Count: 61
    Likes Received:1
    Started working again...

    About a two weeks ago, the iPod started working again. I have two untested theories at this point.

    1. I had the oil changed at my local independent shop, and they oil reset the oil indicator. In the process, they cleared some other settings (clock, date, etc.). I don't know if this kicked some sort of bug out of the system or not.

    2. From what I've read, there may be an issue with simply too many things on the iPod, where any playlist or directory with more than X entries might make the interface bawlk. I don't know what X is (probably some multiple of 8, maybe 512). I swapped out a lot of songs, so maybe that did it.

    Whatever the cause, I'm just going with it at this point.

Share This Page