Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

Incorrect iPod song display on iDrive

Discussion in 'Audio, Video & Electronics' started by dschlesinger, Dec 2, 2011.

    • Member


    Post Count: 1
    Likes Received:0
    About a week after I took delivery of my new 2011 Z4 3.5i, I noticed an problem with how the iDrive displays the currently-playing song on my iPod, which is connected via the USB iPod interface.

    When it works correctly, the display shows the current artist and album on the upper portion of the display, with the name of the song in the lower portion. Sometimes, the lower portion shows a list of all the songs on my iPod in alphabetic order, and the selected song is not the one that's actually playing. When the next song starts playing, the selection on the list moves down to the next entry, but it's still not the right song.

    Initially this happened intermittently, then it started happening most of the time. When it happens, the display might be correct for a minute or two after I start the car, then it starts acting up. Once the display gets messed up, there's no way to fix it. I have the navigation system and premium sound package. My iPod is a few years old -- an iPod classic, 5th generation I think. I have the iPod set to shuffle sounds (on the iPod itself), so it plays back all songs in random order when it's connected. The songs are played in random order as expected, it's just the song display that's wrong.

    I brought the car back to the dealer and showed them the problem, but they didn't have a service bulletin for this particular issue, so they said they couldn't update my software without charging me. I didn't think it was a big enough problem to pay for service (that might not have fixed the problem), so I declined.

    At one point I updated the firmware on my iPod and the problem went away for a while, but it recently started happening again. I posted this information in a different BMW forum a while back, and someone else said they were experiencing the same problem, so it's not just me. Have any of you seen this problem, and if so, do you know of a workaround?
    • Member


    Post Count: 274
    Likes Received:5
    Why not try a newer, more recent iPod? Shouldn't be too difficult to find one to borrow.

    I suggest that based on your observation after you updated your older iPod.

    When you have 2 separate vendors involved, get ready for some heartache when attempting to isolate a problem such as the one you describe. Ask anyone who has experienced bluetooth syncing problems...

    Good luck!

Share This Page