Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

help with X3 and OEM Sirius

Discussion in 'E83 X3 (2004-2010)' started by mbotvinick, Mar 18, 2010.

    mbotvinick guest

    Post Count: 6
    Likes Received:0
    Hey Gang,

    I drive alot. 100+ miles per day easy. I really need my Sirius working. I have a CPO X3 with 70K miles on it. My sat likes to fade in and out when I am listenig to it. This is regardless of where I am at. So its not the geography. It also happens when ever I change stations. It takes a while for the station to come in. this is not the case on my other two cars. In fact the XM on my FLEX runs perfect all the time even under bridges. I had this same problem 50,000 miles ago and the dealer repced the head unit. So I took the car back to a different dealer, and they immed went into the its not covered under warranty blah blah speel before hearing my issues. I really hate BMW dealers here in S. Calif. I wish there was a good one.

    Anyway, anyone have a similar issue. Is there a DIY fix? I do not have the navagation and I have sport and premium package.

    • Member


    Post Count: 141
    Likes Received:1
    I had a similar problem with OE Sirius and took it into the dealer, they fixed a loose connection and it has worked fine since then. XM just has a much stronger signal in my experience. They may be the same company now but use different satellites.

    mbotvinick guest

    Post Count: 6
    Likes Received:0
    Thanks for the response. I dont know why I said XM. My Flex has Sirius. No problems!

Share This Page