Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

Electronic gremlins appearing in my 08 550i

Discussion in 'E60 (2004-2010)' started by jrpisha, Jun 10, 2010.

    • Member


    Post Count: 36
    Likes Received:0
    It had to happen..... Everything was working great. I took the car into a dealer for it's maintenance contract free oil change a month or so ago. Since I've the car back, little things have been going wrong on a daily basis .... little annoying electronic things.

    • Almost every time I start the car, the radio is tuned to a different station.
    • Every other day it seems, the odometer is flipping between miles & kilometers.
    • Once a week, the date / time display is resetting to blank - and I need to re-enter current info.
    • The transmission is constantly upshifting and downshifting - even in easy driving.

    Anybody else experience this sort of thing on their car? I'm hoping that all these issues are symptomatic of a couple of the computers in the car out of synch, and can be remedied by the dealer resetting the computer(s) in the car, but ..... again.... hope is not a strategy.

    Any input would be appreciated.


    bl335i08 guest

    Post Count: 55
    Likes Received:0
    I've had the first three of four things you listed in my '08 x5 3.0si. My problems seem to be related to only one of the two keys I have. When I use my key, all the memory settings stay intact, but whenever I use the other key, I get your problems sans your transmission issue. I've been delaying a visit to my dealer because everything is fine with my key. Our problems might be similar, but not sure. Good luck with it.


    M5WANNABE guest

    Post Count: 3
    Likes Received:0
    Had a similar issue - ended being related to the battery being near its final days. Once the battery was replaced by the dealer - all the electronic gremlin issues went away.
    • Member


    Post Count: 523
    Likes Received:2
    I have to say that definitely sounds like your problem, it probably isn't holding enough power to keep it's memory which is why all your electronics are changing settings

    the transmission sounds like an unrelated problem though, but I'd replace the battery before troubleshooting that, since you never know with all these computers

Share This Page