Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

E39 Touring Wagon - No Speaker Sound

Discussion in 'E39 (1997-2003)' started by Texas Shark, Sep 12, 2010.

    • Member

    Texas Shark

    Post Count: 7
    Likes Received:0
    Last week we had horrendous rainstorms here in Texas. My car sat outside with all windows shut tight. The next morning, the speakers no longer work. The radio comes on like normal with the station and song being played showing on the screen. However, no sound.

    The kids found that the back seat floor was soaking on both sides. The rest of the car is dry, seats, front, etc.

    Question: Are the speakers shorted out? Can a fuse be replaced to get the speakers going again? Where did the water come from?

    Too quiet...suggestion?
    • Member

    jsunma

    Post Count: 16
    Likes Received:0
    Hi There!

    You might do better posting this question over in the Audio/Electronics forum, or perhaps the 5 series forum.

    And when you do, perhaps be a bit more specific about whether you're hearing no sound from ANY of the speakers or just the rear speakers. My guess (and that's all it is) is that there's no "fuse" that could blow because of water but rather that the water has somehow gotten to the amp in the rear of the car (in my 3 series wagon, it's essentially behind the left rear wheel well) and has damaged that. If that were the case, you'd hear no sound from any of the speakers in the car although the headunit (i.e., "the radio") might still light up/display.

    Good luck troubleshooting!
    • Member

    Texas Shark

    Post Count: 7
    Likes Received:0
    Thanks for the reply. No sound is no sound.

    I believe water may have migrated to the amp via the antenna on top of the wagon. The gasket is cracked and weather worn. The amp may now be shorted out and likely will need to be replaced.

Share This Page