Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

e39 540i fuel filter chattering

Discussion in 'E39 (1997-2003)' started by ual767flyr, Jun 24, 2015.

    • Member

    ual767flyr

    Post Count: 7
    Likes Received:1
    I have a 2002 540i/6 100k miles.

    The car runs and starts fine.

    I had the original fuel filter replaced and after about 30 miles the fuel filter is making a chattering noise and vibration. Indy shop replaced it again and after 30 miles, it began to chatter again. Sounds like a old diesel car.

    Anybody have any ideas?

    Thanks, Mike
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,255
    Likes Received:126
    What kind of the fuel filter did you put in?
    • Member

    ual767flyr

    Post Count: 7
    Likes Received:1
    Don't know the part number but it was a
    Hengst Filter.
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,255
    Likes Received:126
    Is the filter chattering or the engine?
    • Member

    ual767flyr

    Post Count: 7
    Likes Received:1
    Yep its the filter. You can put hand on the shroud and feel and hear the vibration. Car is getting more difficult to start now too. I've never had a problem with starts. I'm gonna take it to a dealer next week.
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,255
    Likes Received:126
    I would check to make sure the filter isn't installed backwards. There should be a arrow pointing in the direction of flow. Also may wanna try a oe filter to.
    • Member

    ual767flyr

    Post Count: 7
    Likes Received:1
    Went to dealer. Said fuel pump output pressure was low and return pressure was really low. Now I don't know how swapping out a fuel filter could have any effect on a fuel pump? 100K miles on the original filter.

    Installed OEM fuel filter and a new fuel pump. Now it works and sounds fine.

    As a side note, They had to order parts for my repair a gave me a loaner loaded 335d Xdrive. My first experience with a diesel and BMW connect. Not a fan of the BMW connect. Seems like a steep learning curve.

    The diesel sounded a bit "tractor-ish" and harsh off the line. I was expecting more low end torque off the line too. seems the turbos didn't spool up till above 2000 rpm? The stop/start at traffic lights was weird the first few times. I was praying that when it was time to go that it would start!

    My e39 is 13 yrs old and drove/handled better than that loaner!
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,255
    Likes Received:126
    Glad everything is fixed on your car!

Share This Page