Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

AC blower fans wouldn't run

Discussion in 'E46 (1999-2006)' started by EvaUnit02, Jun 18, 2009.

    • Member

    EvaUnit02

    Post Count: 74
    Likes Received:0
    I have a 2001 330xi and on the drive home, the cabin fans weren't on for a few minutes. They eventually kicked in and I couldn't replicate the problem.

    I had the temperature set to 70 degrees auto, auto air control, and AC enabled. Now, it was roughly the same temperature outside but I can't imagine the fans would just turn off like that. I'd like to check to make sure the power cable is securely connected to the blower motor but I don't know where that is located on the car. Could anyone help me out or otherwise tell me if I'm off the mark?

    M3Driver guest

    Post Count: 619
    Likes Received:3
    • Member
    • Technical Service Advisor

    mooseheadm5

    Post Count: 1,880
    Likes Received:15
    + several million.
    It is the blower motor final stage "resistor" (actually a transistor pack.) They go bad all the time.
    • Member

    EvaUnit02

    Post Count: 74
    Likes Received:0
    Great. Thanks a lot, guys!
    • Member

    EvaUnit02

    Post Count: 74
    Likes Received:0
    Sure enough, that was it. The mechanic also said something about a tear in the air intake or some such. It wasn't an expensive fix so I'm having that repaired, too. He said it was fairly common. Anyone know what he's talking about?
    • Member
    • Technical Service Advisor

    mooseheadm5

    Post Count: 1,880
    Likes Received:15
    Probably a torn intake boot. Very very common as well. The part is in the $30 range and labor is cheap on that gig.

    bmw brad guest

    Post Count: 19
    Likes Received:0
    • Member

    sunnyandrich

    Post Count: 19
    Likes Received:0

Share This Page