Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

2005 545 reliability

Discussion in 'E60 (2004-2010)' started by jblakejr, May 23, 2008.

    jblakejr guest

    Post Count: 3
    Likes Received:0
    IJust about to purchase certified 2005 545i with sport package. Any generic reliability issues on this model I should review with dealer to be sure they've been dealt with? Thanks...jblakejr

    Autohaus guest

    Post Count: 1,571
    Likes Received:1
    I-Drive option?

    jblakejr guest

    Post Count: 3
    Likes Received:0
    Yes. I-drive

    niemibl guest

    Post Count: 0
    Likes Received:0
    I have a 2005 545i. I bought it 16 months ago and it had 23,000 miles on it. It now has 51,000 miles and other than a couple of service bulletins I have not had any problems at all. The service bulletins were for the Dunlop run-flat tires ( I got four new tires at no charge), the door seals and the passenger seat belt sensor. I have not had any problems with Idrive.

    jblakejr guest

    Post Count: 3
    Likes Received:0
    2005 545i

    Thanks for the info..good luck with yours...i pick mine up this week...j

    vetconstruction guest

    Post Count: 1
    Likes Received:0
    We purchased an 04 545 and haven't had any issues-I drive-well, I read the manual and we love it.
    Congrates on your purchase

    NoWalnuts guest

    Post Count: 2
    Likes Received:0
    545 Cpo

    I have not had the best luck with my 04 545i - 6sp Sport Pkg.
    Computer reprogramed twice then had the CPU replaced.
    Clutch went out at 49K miles.
    A/C compressor shot at 51K miles.

    Glad I have the CPO warranty but still a PITA with all the visits.

    jgnj545 guest

    Post Count: 2
    Likes Received:0
    I purchased a 2005 545 in June. I have had no major problems and already have 12K miles on the car. I have had 1 oil change (no charge) and also had it in becasue the FTM when off. I thought the problem was in FTM because I could not determine a flat. It turns out one of my tires had a small punture the would occasionally set the FTM off. They fixed the tire at no charge.

Share This Page