Hello there and welcome to the BMW Car Club of America.

If you are a BMW CCA member, please log in and introduce yourself in our Member Introductions section.

2001 E39 Cooling System

Discussion in 'E39 (1997-2003)' started by manuej, Feb 13, 2018.

    • Member

    manuej

    Post Count: 2
    Likes Received:0
    Over the past 3 years I've had to replace my water pump 4 different times. At first I thought I just had a bubble in the system but after bleeding it weekly, then daily I was still having off and on overheating issues. The first time I replaced the OEM plastic impeller water pump with a newer aluminum version but that failed within 2 weeks. After that I took it to my local shop (German Autowerks - highly recommended) and they replaced it again for me. 2 months later that failed again (and they replaced it under warranty).

    After flushing the system and seeing no kinks or holdups in the flow I figured it had to be the pump again and sure enough it was. After doing the timing chain cover gaskets and valve cover gaskets it stopped functioning once more.

    Any thoughts on why it keeps failing?

    P.S. I'm new to this forum so I'm sure I've left out information. Please feel free to ask and I'll answer what I know.
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,095
    Likes Received:117
    I would check to make sure the fan is in good condition and clutch is ok as well. I have seen broken fans become unbalanced and damage the bearings of the pump.
    manuej likes this.
    • Member

    manuej

    Post Count: 2
    Likes Received:0
    Thanks for the reply. I checked the fan and the clutch seems okay but I do hear some wobble every once in a while on startup.
    • Member
    • Technical Service Advisor

    charlson89

    Post Count: 2,095
    Likes Received:117
    What keeps failing on the pump? Does the impeller break off?

Share This Page